Blog - Savers Admin Payroll Platform Free of Heartbleed Vulnerability

Savers Admin Payroll Platform Free of Heartbleed Vulnerability

You may have heard news of the ‘Heartbleed Bug’ that has affected security on some websites.  The Heartbleed Bug is a serious vulnerability in the popular OpenSSL software library.  OpenSSL is used by many websites to provide secure communications between the website and its users.

Our Evolution payroll services have never used a vulnerable version of the OpenSSL library, and they have never supported the “heartbeat extension” that’s at the center of this vulnerability.  Any attempts by a hacker to exploit this software bug on the Evolution payroll platforms will fail.  This has been verified by the Evolution software vendor as well as a third-party network security consultant.

For more information about the Heartbleed Bug, please visit www.heartbleed.com.